UkrReferat.com
найбільша колекція україномовних рефератів

Всього в базі: 75843
останнє поновлення: 2016-12-04
за 7 днів додано 15

Реферати на українській
Реферати на російській
Українські підручники

$ Робота на замовлення
Реклама на сайті
Зворотній зв'язок

 

ПОШУК:   

реферати, курсові, дипломні:

Українські рефератиРусские рефератыКниги
НазваУпровадження таблиць (реферат)
Автор
РозділІнформатика, компютерні науки
ФорматWord Doc
Тип документуРеферат
Продивилось2712
Скачало369
Опис
ЗАКАЧКА
Замовити оригінальну роботу

рки вниз по стовпчику до

рядка 26:

 

 

Усі позначені комірки заповнюються обчисленими значеннями, при цьому

посилання на коефіцієнти залишаються у формулах без змін, а посилання на

значення Х змінюється залежно від нового положення формули, тобто

реалізується циклічний алгоритм.

 

Для обчислення Y2, Y3 та Y4 використовується логічна функція ЕСЛИ. Вона

реалізує алгоритм із розгалуженням і містить три аргументи:

 

=ЕСЛИ(умова; дія, якщо умова ІСТИННА; дія, якщо умова ХИБНА)

 

Етапи розв’язання задачі:

 

У випадку обчислення виразу Y2 перевіряється, чи поточне значення Х

більше за 10 і, якщо ця умова виконується, то обчислення провадиться за

виразом:

 

 

якщо ж умова не виконується, обчислення провадиться за виразом

 

.

 

Повний текст функції:

 

=ЕСЛИ(C20>10;EXP(SIN(C20))–

 

КОРЕНЬ(C20^3);LN(ABS(C20)+1)–COS(C20^2+C20–3,14*$A$20*$B$20))

 

Блок-схема алгоритму вирішення задачі подана нижче.

 

 

Так само, як у попередньому виразі, текст функції можна вводити або з

клавіатури, або користуватися послугами Майстра функцій:

 

 

Перший рядок аргументів містить умову С20>10;

 

Другий рядок аргументів містить формулу, якщо умова виконується — вираз

EXP(SIN(C20))-КОРЕНЬ(C20^3).

 

Третій рядок аргументів містить формулу, якщо умова

 

не виконується — вираз LN(ABS(C20)+1)–COS(C20^2+C20–3,14*$A$20*$B$20)

 

При цьому знову викликаються вкладені функції — EXP, SIN, КОРЕНЬ, LN,

ABS, COS. Після введення всього тексту треба повернутися у викликаючу

функцію ЕСЛИ і натиснути на Ok.

 

У деяких випадках, якщо формула містить помилки, може з’явитися вікно

повідомлень:

 

 

Microsoft Excel запропонує виправити помилку, і треба або погодитися

(кнопка Да), або ні (кнопка Нет) і тоді вносити виправлення самостійно.

 

Якщо ж формула помилок не містила, обчислене значення запишеться в

активну комірку.

 

Для визначення виразу Y3 так само використовують

 

функцію ЕСЛИ, проте аргументами функції є не тільки формули для

обчислення виразу, а й укладені функції ЕСЛИ

 

у випадку, якщо введена умова виконується або не виконується.

 

У даному випадку значення функції може визначатися :

 

 

4. При x > 20 функція Y3 не визначена

 

5. При x = 6 функція Y3 не визначена

 

Реалізується алгоритм з розгалуженням і перевіркою складної умови.

 

z

 

|

 

ю

 

-

 

Љ

 

љ

 

њ

 

к

 

м

 

о

 

Ћ

 

-

 

њ

 

м

 

ъ

 

???y????????^?о

 

р

 

??

 

??

 

??

 

??

 

??

 

??

 

??

 

??

 

??

 

??

 

??

 

??

 

??

 

©

 

©

 

©

 

©

 

Ѕ

 

Ѕ

 

Ѕ

 

 

.не визначене (позиція 5). І нарешті, якщо і ця умова не виконується,

залишається інтервал, де значення Х автоматично стає меншим за 6, тобто

записується вираз для обчислення за позицією 1.

 

Повний текст функції Y3 показаний нижче:

 

=ЕСЛИ(C20<6;СТЕПЕНЬ($B$20*C20;1/3);ЕСЛИ(C20=6;

"невизначена";ЕСЛИ(C20>20;"невизначена";ЕСЛИ(С20>14; EXP($A$20*$B$20*

 

C20); LN($A$20*$B$20+C20^3)))))

 

Нижче наведена блок-схема алгоритму:

 

 

Перший етап перевірки:

 

 

Другий етап перевірки:

 

 

Третій етап перевірки:

 

 

Четвертий етап перевірки:

 

 

Потім натискається Ok, обчислене значення записується у комірку і

копіюється униз по стовпчику до рядка 27.

-----> Page:

[0] [1] [2] 3 [4] [5] [6] [7]

ЗАМОВИТИ ОРИГІНАЛЬНУ РОБОТУ