UkrReferat.com
найбільша колекція україномовних рефератів

Всього в базі: 75843
останнє поновлення: 2016-12-04
за 7 днів додано 10

Реферати на українській
Реферати на російській
Українські підручники

$ Робота на замовлення
Реклама на сайті
Зворотній зв'язок

 

ПОШУК:   

реферати, курсові, дипломні:

Українські рефератиРусские рефератыКниги
НазваГрафічне представлення даних. Структурування масивів даних у таблицях (реферат)
Автор
РозділІнформатика, компютерні науки
ФорматWord Doc
Тип документуРеферат
Продивилось3482
Скачало392
Опис
ЗАКАЧКА
Замовити оригінальну роботу

опка Убрать все. Таблиця набуде вигля-

 

ду, який вона мала перед упровадженням проміжних під-

 

сумків.

 

Проведення деяких проміжних підсумків

 

за допомогою стандартних функцій

 

Microsoft Excel

 

Для підрахунку суми числових значень у певному діапазоні

використовується функція СУММ (діапазон комірок), проте вона підраховує

суму із усіх значень, розташованих у вказаному діапазоні. Коли ж

потрібно підрахувати суму числових значень, які відповідають певній

умові у таблиці, використовується функція СУММЕСЛИ, яка має такий

вигляд:

 

=СУММЕСЛИ(діапазон для перевірки умови; «умова»; діапазон для підрахунку

суми).

 

Принципом роботи функції є перегляд значень у діапазоні умови і, якщо є

значення, що відповідають умові, вираховується по тих же рядках сума

числових значень у діапазоні підрахунку суми.

 

Наприклад, за даними попередньої таблиці треба підрахувати суму податку,

що сплатив клієнт Іванов.

 

Діапазоном для перевірки умови є стовпчик з прізвищами клієнтів —

В12:В24, серед яких зустрічається (або ні) потрібне прізвище.

 

Умовою для пошуку є прізвище «Іванов», а діапазоном для підрахунку суми

значень є стовпчик з нарахованими податками — І12:І24. Тоді функція

набуває такого вигляду:

 

=СУММЕСЛИ(В12:В24;«Іванов»;І12:І24)

 

 

Після введення функції у вільну комірку таблиці буде отримано результат

підрахунку:

 

 

Умова може бути не тільки текстовою, а й числовою: наприклад,

підрахувати загальну кількість виробів, замовлених до 1998 року.

 

Діапазоном для перевірки умови буде стовпчик із датами замовлення —

С12:С24, умовою мають бути дати до 1 січня 1998 року, тобто «<01.01.98»,

а діапазоном даних для суми є стовпчик з кількістю виробів — F12:F24.

Функція буде виглядати так:

 

=СУММЕСЛИ(С12:С24;«<01.01.98»;F12:F24)

 

 

"

 

x

 

z

 

|

 

Є

 

x

 

z

 

І

 

Ё

 

Є

 

в

 

Є

 

¬

 

®

 

°

 

І

 

 

 

 

Ё

 

Є

 

¬

 

Ъ

 

Ь

 

Ю

 

а

 

в

 

j

 

ътъкътътъжажътътътътъХътъНжјґНжътъНжЈ›Нъ•Ќ•ъ†ътъъ

 

j

 

 

.загальної кількості замовлених принтерів функція СУММЕСЛИ матиме такий

вигляд:

 

=СУММЕСЛИ(Е12:Е24;«Принтер»;F12:F24)

 

Інша функція для підрахунку з умовою — це функція СЧЕТЕСЛИ:

 

=СЧЕТЕСЛИ(діапазон для перевірки умови; «умова»)

 

У процесі роботи цієї функції проглядається діапазон для перевірки умови

і підраховується кількість виконань умови.

 

Наприклад,

 

визначити, скільки разів робив замовлення клієнт Іванов:

 

Діапазон для перевірки — В12:В24, умова — «Іванов».

 

Функція має такий вигляд:

 

=СЧЕТЕСЛИ(В12:В24;«Іванов»)

 

визначити, скільки разів робились замовлення до 1998 року:

 

Діапазон для перевірки — С12:С24; умова — «<01.01.98».

 

Функція має такий вигляд:

 

=СЧЕТЕСЛИ(С12:С24;«<01.01.98»)

 

визначити, скільки разів замовлялися принтери:

 

Діапазон для перевірки — Е12:Е24, умова — «Принтер».

 

=СУММЕСЛИ(Е12:Е24;«Принтер»; F12:F24)

 

Нижче показані тексти функцій та результати підрахунків:

 

Приклад функції СУММЕСЛИ Результат

 

=СУММЕСЛИ(B2:B14;"Іванов";I2:I14) 4572

 

=СУММЕСЛИ(C2:C14;"<01.01.98";F2:F14) 320

 

=СУММЕСЛИ(E2:E14;"Принтер";F2:F14) 142

 

Приклад функції СЧЕТЕСЛИ

 

=СЧЁТЕСЛИ(B2:B14;"Іванов") 4

 

=СЧЁТЕСЛИ(C2:C14;"<01.01.98") 5

-----> Page:

[0] [1] [2] [3] 4 [5] [6] [7] [8] [9]

ЗАМОВИТИ ОРИГІНАЛЬНУ РОБОТУ