UkrReferat.com
найбільша колекція україномовних рефератів

Всього в базі: 75843
останнє поновлення: 2016-12-04
за 7 днів додано 10

Реферати на українській
Реферати на російській
Українські підручники

$ Робота на замовлення
Реклама на сайті
Зворотній зв'язок

 

ПОШУК:   

реферати, курсові, дипломні:

Українські рефератиРусские рефератыКниги
НазваНабуття практичних навичок виконання розрахунків в середовищі табличного процесора Excel (реферат)
Автор
РозділІнформатика, компютерні науки
ФорматWord Doc
Тип документуРеферат
Продивилось7200
Скачало453
Опис
ЗАКАЧКА
Замовити оригінальну роботу

к, то за умовою функція Y3 не визначена (4 позиція). У

противному разі значення Х менше або дорівнює 20, проте Х = 3, Х = 6, Х

= 12, Х = 20 також менші або дорівнюють 20, тому, якщо перша умова не

виконується, треба знову викликати вкладену функцію ЕСЛИ і зробити

перевірку, чи значення Х > 14 і тим самим визначити інтервал, у якому

функція Y3 визначається за позицією 3. Якщо ж і ця умова не виконується,

то знову викликається функція ЕСЛИ і перевіряється умова, чи значення Х

> 6, тобто визначається інтервал, у якому функція Y3 визначається за

позицією 2. Якщо ж умова і тепер не виконується, то знову викликається

функція ЕСЛИ і перевіряється умова, чи значення Х = 6, тоді значення

функції Y3 не визначене (позиція 5). І нарешті, якщо і ця умова не

виконується, залишається інтервал, де значення Х автоматично стає меншим

за 6, тобто записується вираз для обчислення за позицією 1.

 

13.2. Повний текст функції Y3 показаний нижче:

 

=ЕСЛИ(C20<6;СТЕПЕНЬ($B$20*C20;1/3);ЕСЛИ(C20=6;

"невизначена";ЕСЛИ(C20>20;"невизначена";ЕСЛИ(С20>14; EXP($A$20*$B$20*

 

C20); LN($A$20*$B$20+C20^3)))))

 

Нижче наведена блок-схема алгоритму:

 

 

13.3 Перший етап перевірки:

 

 

13.4. Другий етап перевірки:

 

 

13.5. Третій етап перевірки:

 

 

13.6. Четвертий етап перевірки:

 

 

13.7 Потім натискається Ok, обчислене значення записується у комірку і

копіюється униз по стовпчику до рядка 27.

 

У наведеному вище прикладі всі умови, що перевірялися, були простими,

тобто за один раз перевірялася лише одна умова, проте відокремлювалися і

визначалися інтервали, в яких функція Y3 набувала того чи іншого

значення (позиції 1—5).

 

14. Ті ж самі інтервали можна визначити за допомогою складної перевірки.

Наприклад, значення функції Y3 не визначене, якщо Х або дорівнює 6, або

більший за 20 (позиції 4 та 5), якщо ж значення Х лежить у інтервалі, де

Х більший за 6 та менший або дорівнює 14, то значення функції Y3

обчислюється за позицією 2, в інтервалі, де Х змінюється від значення,

що більше за 14, але менше та дорівнює 20, то значення функції Y3

обчислюється за позицією 3, якщо ж Х не лежить у жодному з перерахованих

інтервалів, то він автоматично розташований в інтервалі, що менший за 6,

і тоді функція Y3 визначається за позицією 1.

 

14.1 Для організації складних перевірок використовують логічні функції И

або ИЛИ, кожна з яких може містити максимум 30 простих умов:

 

=И(умова 1; умова 2; умова 3; …; умова 30)

 

=ИЛИ(умова 1; умова 2; умова 3; …; умова 30).

 

Функція И набуває значення ІСТИНА, якщо кожна перерахована у ній умова

виконується, і набуває значення ХИБА, якщо хоча б одна з перерахованих

умов не виконується.

 

Функція ИЛИ набуває значення ІСТИНА, якщо хоча б одна з перерахованих

умов виконується, і набуває значення ХИБА, якщо жодна з указаних умов не

виконується.

 

І функцію И, і функцію ИЛИ можна використовувати як перший аргумент

умови у складі функції ЕСЛИ.

 

Повний текст функції для визначення значення Y4 із застосуванням

вкладених функцій И та ИЛИ показаний нижче:

 

=ЕСЛИ(ИЛИ(C20>20;C20=6);"невизначена";ЕСЛИ(И(C20>14;C20<=20);EXP($A$20*$

-----> Page:

[0] [1] [2] [3] [4] [5] [6] [7] [8] 9 [10] [11] [12]

ЗАМОВИТИ ОРИГІНАЛЬНУ РОБОТУ